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  Safety
 

 NOTE: Read this manual before using GTR-01 random number generator.

  Do not expose this device to impacts beyond the limits specified in the CAUTION:
documenta�on! Use this instrument in conjunc�on only with products that are in compliance with the 
quality and safety standards. 
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 Benev Science & Technology warrants that this product will be free from defects in  Ltd. 
materials and workmanship for a period of two (2) years from the date of shipment. If any such product  
proves defec�ve during this warranty period Benev Science & Technology will repair ,  Ltd., at its op�on, 
the defec�ve product without charge for parts and labor, or will replace it.

 – The product has been under impacts beyond the limits specified in its documenta�on or has 
been used in conjunc�on with defec�ve products or such that are not in compliance with the quality 
and safety standards.

 This warranty shall not apply to any defect, failure or damage caused by improper use or 
improper or inadequate maintenance and care. Benev Science & Technology shall not be obligated  Ltd. 
to furnish service under this warranty in the following cases:
 – The product has been disassembled, modified, or repaired by persons who have not been 
explicitly authorized for this by  Ltd. and in the event of damage or Benev Science & Technology
replacement of warranty s�ckers.

 

 It is customer’s responsibility to no�fy us in the event of a defect occurring within the warranty 
period, as well as packing prepara�on and payment of the transporta�on costs to the our office. Benev 
Science & Technology Ltd. bears the transporta�on costs of delivering the repaired or replaced product 
back to the customer.

 – In the case of natural disaster, such as fire, earthquake, flood, etc.

  Warranty 
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GTR-01 is a hardware system genera�ng true random numbers. The innova�ve mul�pla�orm 
design, convenient USB interface, the high data rate of up to 2.2 Mb/s and the compact size of GTR-01, 
make it the right choice for many applica�ons related to cryptography and security, scien�fic research, 
computer simula�ons, modeling, lo�eries, gambling, applied mathema�cs and sta�s�cs, etc. In many 
of the above areas, it is important to use a source of random numbers based on a physical 
phenomenon, unlike the computer-generated pseudo random numbers using a known and 
predictable numerical algorithm.

The GTR-01 is developed with a vision for the requirements of modern hardware design, 
providing security and func�onal reliability on the one hand and a sufficiently simplified and op�mized 
so�ware interface for high-speed communica�on with the PC, on the other. The work of GTR-01 is 
based on a physical phenomenon called avalanche noise in the reverse-biased p-n junc�on and is 
quantum in its nature, indeed. That makes it an appropriate choice as the source of entropy in 
hardware random number generators.

  1. Overview

 1.1 Basic features

Quantum phenomenon as a physical source of entropy

Two completely independent analog channels with so�ware XOR func�on

12-bit precise calibra�on on every channel with EEPROM values storage

Data rate up to 2.2 Mb/s random bits through a standard USB interface

Mul�pla�orm design including Windows, Linux, Mac OS and Android

Compact and robust aluminum shielded enclosure

GTR-01 Features

Programming API including GUI applica�on, examples and low-level drivers 

 1.2 Applica�ons

  Cryptography and security    Scien�fic research

  Lo�eries and gambling    Computer simula�ons

  PIN genera�on     Sta�s�cs

Sta�s�cally proven output data stream quality
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  2. GTR-01  

 2.1 Device overview

 

G
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GTR-01 Front panel

1

2

1. USB mini connector
2. Status LED

GTR-01 (top view)
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 The generated noise in this process has 
a complicated structure. It consists primarily of 
quantum shot noise with the addi�on of the 
avalanche excess noise as a consequence of 
the internal amplifica�on. The reverse-biased 
voltage at which described avalanche process 
occurs is known as a breakdown voltage. 

R .everse-biased p-n junc�on

p-n junc�on

Deple�on regionN-region P-region

 Under a reverse-bias voltage, the p-n 
junc�on's deple�on region widens. Thus, a 
high-strength electric field arises across the 
junc�on. Unbound by random thermal 
fluctua�ons, nega�ve charge carriers 
(electrons) and posi�ve ones (holes) will 
move towards the posi�ve and nega�ve 
electrodes, respec�vely. If the electric field 
is strong, the electrons and holes will be 
accelerated to high enough speeds to knock 
other bound electrons free which will be 
accelerated too and so on, thus crea�ng an 
avalanche and increasing the current.

 2.2 Noise genera�ng process

GTR-01 uses a physical phenomenon known as avalanche noise in the reverse-biased p-n 
junc�on as a primary source of entropy.
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 2.4 Technical specifica�ons

Specifica�ons

Noise source

Number of independent channels

XOR

Max bit rate

Opera�ng temperature range

Dimensions

Weight

Avalanche noise, reverse-biased p-n junc�on

2 

Yes

2.2 Mb/s

0 ÷ 50 °C

74 x 41 x 15 mm

50 g

Specifica�ons

Pla�orm Windows, Linux, Mac OS, Android

 2.3 Basic scheme

The basic device scheme is shown below.

GTR-01 basic scheme.

 GTR-01 has two independent analog channels. In every channel, the signal from the physical 
noise source is amplified to the level suitable for detec�on and is connected to the one input of a high-
speed analog comparator. The other comparator’s input is fed by a 12-bit digital-to-analog converter 
and is used to precisely calibrate the channel. Analog comparators outputs connect to the MCU and 
the 0's and 1's are further processed. Communica�on of the GTR-01 with the PC is through a USB 
interface.
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   In the Device Manager right-Step 2.
click on the device and choose Proper�es from 
the drop-down menu. In the Driver tab click 
Update Driver bu�on.

 2.5 Driver installa�on

 For proper opera�on, the GTR-01 need the USB driver pack to be installed. You can download 
drivers from the tech info sec�on on the product’s page: www.benev.biz/en/quantum-random-
generators.html
 The example below demonstrates the driver installa�on procedure on Windows 10. For other 
pla�orms, the installa�on follows similar steps, but you need to use a proper driver pack.

   Connect GTR-01 to the PC. Step 1.
When device is connected for the first �me, 
Windows automa�cally installs some driver by 
default, but this is not the correct one. In the 
Device Manager the device is displayed with a 
yellow warning mark, as is shown on the le�.
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   Op�onally, a�er successful Step 6.
driver installa�on, in the Device Manager, right-
click on the device and choose Proper�es from 
the drop-down menu. In the Advanced tab, you 
can choose whether to load the Virtual COM 
Port driver and communicate with GTR-01 as a 
serial COM Port device.

  In the next window choose Step 3.
Browse my computer for driver so�ware.

   Click the Browse bu�on and Step 4.
navigate to the folder containing the driver 
pack.

   Wait just a moment for the Step 5.
driver to be installed successfully.
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 A�er successful driver installa�on,   
GTR-01 is displayed in the Device Manager, 
under the USB controllers node, as an properly 
working USB Serial Converter.
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  3. StudioGTR

  For proper communica�on between StudioGTR and GTR-01, USB drivers should be NOTE:
installed. Fore more informa�on on how to install the driver pack, please see previous sec�on.

 You can download the so�ware from the tech info sec�on on the product’s page: 
www.benev.biz/en/quantum-random-generators.html
 

 StudioGTR is a compact and very easy-to-use Windows-based GUI applica�on intended to 
monitor the opera�on, genera�on of random numbers and random symbolic sequences, performing 
sta�s�cal tests and calibra�on of the GTR-01. Op�mized user interface and simplified work with the 
applica�on allow for a quick visual check of basic device performance. 

 3.1 System requirements

Specifica�ons

Opera�ng system

CPU

RAM

Screen resolu�on

Hard disk free space

 Windows XP*, Vista, 7, 8, 8.1, 10; 32-bit / 64-bit

 1 GHz or be�er; 32-bit / 64-bit 

1 GB or more

1024 x 768 or higher

50 MB or more

Requrements

USB 2.0, 3.0 or 3.1 single port

 * Windows XP requires .NET Framework 2.0 or higher to be installed.

 StudioGTR does not need to be installed at all. Just unpack the StudioGTR.zip file somewhere 
on your system, for example, in the C:\Program Files\StudioGTR and put a shortcut to the applica�on’s 
.exe file on your Desktop or Start menu. That's all.

 3.2 Applica�on installa�on

 NOTE: Do not change the structure and content of the unpacked zip archive.

Adobe Acrobat Reader Version 9.0 or higher
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 3.3 Main screen

 StudioGTR’s main screen is shown on the figure below. 

 

Menu bar

Ac�ve instrument screen

Status bar

StudioGTR main screen.

Progress bar

 3.4 StudioGTR basic features

 StudioGTR has two modes of random number genera�on:

 True   as a random number generator. , – uses GTR-01 To ac�vate this mode from the Main 
menu click Mode → True.
 

 . Pseudorandom – uses built-in so�ware pseudorandom number generators To ac�vate this 
mode from the Main menu click , .Mode → Pseudorandom

 :NOTE  The current opera�onal mode and device status are shown on the right side of the 
menu-bar. 
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 Integer Numbers – generates random sequences of integer numbers between min and max 
values.

  – generates some types of random noise.Random Noise
  – generates random sequences of symbols.Strings

 
 StudioGTR offers a few instruments to work with random events and numbers:
 Visualizer – it is used for the quick visual check of the quality of random numbers.

 Float Numbers – generates random sequences of floa�ng-point numbers between min and 
max values.

  – generates images with a random distribu�on of the pixel values.Bitmaps
  – generates lucky lo�ery numbers.Lo�ery Numbers
  – generates random numbers with sampling rate in autonomous mode Random Event Logger
and records data to the PC’s hard drive.
  – performs an automa�c sta�s�cal check of the used random generator.Sta�s�cal Tests
  – calibrates GTR-01 in manual or automa�c mode. Calibra�on

 NOTE: You can save the applica�on’s screen as an image using the Main menu File → Save 
Screen... or Ctrl+G keyboard shortcut.

10
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 3.5 Tools

 , . It allows for a quick visual To ac�vate this mode from the Main menu click Tools  Visualizer→
check of the generated random numbers to be performed.

 3.5.1 Visualizer
 

StudioGTR Visualizer.

 In the  sec�on, you can set the count of the generated random points. Control

11
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 3.5.2 Integer Numbers
 
 , . This instrument To ac�vate this mode from the Main menu click Tools  Integer Numbers→
generates integer random numbers between min and max values.

StudioGTR Integer Numbers.

 In the  sec�on, you can set the min and max values. If the Bit Stream op�on is chosen, the Range
values are in the range from -2³¹ to +2³¹-1. Use this op�on to generate bit sequences.
 
 In the  sec�on, you can set the count of the generated numbers. Length

 :NOTE  Generated integer numbers are of type 32-bit signed integer.

 In the  sec�on, you can save the generated random sequence to the file (text or binary). If Save
the file is in text format, you can set the delimiter, numeral system (decimal or hexadecimal) and 
column number.
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 3.5.3 Float Numbers

 , . To ac�vate this mode from the Main menu click This instrument Tools  Float Numbers→
generates floa�ng-point random numbers between min and max values.

StudioGTR Float Numbers.

 :NOTE  The generated numbers use the built-in .NET formats for floa�ng-point numbers, 
according to the relevant interna�onal standards.

 In the  sec�on, you can set the count of the generated numbers. Length

 In the  sec�on, you can set the precision (Single – 32-bit or Double – 64-bit) and the min Range
and max values.

 In the  sec�on, you can save the generated random sequence to the file (text or binary). If Save
the file is in text format, you can set the delimiter, scien�fic nota�on (1.0e+00 or 1.0E+00) and column 
number.
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 , . To ac�vate this mode from the Main menu click This instrument generates Tools  Strings→
character strings.

 3.5.4 Strings

StudioGTR Strings.

 abcdefghijklmnopqrstuvwxyz

 01
 ΑΒΓΔΕΖΗΘΙΚΛΜΝΞΟΠΡΣΤΥΦΧΨΩ

 +-

 абвгдежзийклмнопрстуфхцчшщъьюя

 0123456789

 АБВГДЕЖЗИЙКЛМНОПРСТУФХЦЧШЩЪЬЮЯ

 abcdef
 ABCDEF

 αβγδεζηθικλμνξοπρστυφχψω

 .-

 In the  sec�on, you can choose the combina�on of symbol groups used to generate the Symbols
string. The possible combina�ons are:

 ABCDEFGHIJKLMNOPQRSTUVWXYZ
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 In the  sec�on, you can set the string length. Length

 In the  sec�on, you can set the row number.Save

 NOTE: Strings are always saved in the text format file.
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 3.5.5 Random Noise
 
 , . To ac�vate this mode from the Main menu click This instrument Tools → Random Noise
generates random noise of a few types.

StudioGTR Random Noise.

 In the  sec�on, you can set the noise type and the precision (Single – 32-bit or Double – Format
64-bit). StudioGTR generates a few types of random noise:
 White noise. The applica�on generates N(0, 1) numbers using Box-Muller Transform.

 In the  sec�on, you can set the count of the generated numbers. Length

 In the  sec�on, you can save the generated random sequence to the file (text or binary). If Save
the file is in text format, you can set the delimiter, scien�fic nota�on (1.0e+00 or 1.0E+00) and column 
number.

 Flicker noise (1/f  or Pink noise). StudioGTR uses the algorithm shown in MGardner . 
“Mathema�cal games-white and brown music, fractal curves and one-over-f fluctua�ons”, Scien�fic 
American, 238(4):16–32, 1978.
 Brown (Red) noise. It is also known as Random Walk.
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 3.5.6 Bitmaps
 
 , . To ac�vate this mode from the Main menu click This instrument generates Tools → Bitmaps
square images with random distribu�on of the pixel values. 

StudioGTR Bitmaps.

 Color. The pixels can take RGB color values. Every color component (red, green and blue) is in 
the range between 0 and 255.

 Gary. The pixels can take monochrome values between 0 (black) and 255 (white).
 B&W. The only pixel values are 0 (black) or 255 (white).
 In the  sec�on, you can set the image size and type:Control
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 3.5.7 Lo�ery Numbers
 
 , . To ac�vate this mode from the Main menu click This instrument Tools → Lo�ery Numbers
generates lucky lo�ery numbers. 

StudioGTR Lo�ery Numbers.

 In the  sec�on, you can set the numbers count, ini�al value (0 or 1) and range from Control
which to generate. For example, playing Lo�o 6/49, choose 6 numbers with values from 1 to 49, 
playing Lo�o 5/35, choose 5 numbers with values from 1 to 35, and so on.
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 , . To ac�vate this mode from the Main menu click This Tools → Random Event Logger
instrument generates random numbers with the given sampling rate in con�nuous mode and 
automa�cally saves the data to the Pc’s hard drive. The tool only makes sense in  mode and is  True
suitable for monitoring the impact of natural phenomena on the opera�on of the GTR-01. In the  
same manner, it allows the use of GTR-01 to register such phenomena.

 3.5.8 Random Event Logger

StudioGTR Random Event Logger.

 In the  sec�on, you can set the count of the generated numbers. Length

 In the  sec�on, you can set the recorded �me type (Local �me or Universal Time Save
Coordinated, UTC), and set the delimiter and scien�fic nota�on (1.0e+00 or 1.0E+00).

 In the  sec�on, you can set the precision (Single – 32-bit or Double – 64-bit) and the min Range
and max values. Dat are floa�ng-point numbers.

 :NOTE  Data are always recorded in text file format. To choose the save directory, see sec�on 
3.8.

 In the  sec�on, you can set the sampling rate between 1 s and 60 minutes.Control
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 , . To ac�vate this mode from the Main menu click This instrument Tools → Sta�s�cal Tests
checks the output quality of the currently selected random generator in the program. It implements a  
specially developed ba�ery of sta�s�cal tests.

 3.5.9 Sta�s�cal Tests
 

StudioGTR Sta�s�cal Tests.

h�ps://csrc.nist.gov/publica�ons/detail/sp/800-22/rev-1a/final

 :NOTE  StudioGTR uses sta�s�cal test ba�ery published by Na�onal Ins�tute of Standards and 
Technology (NIST). For more info, please read “A Sta�s�cal Test Suite for Random and Pseudorandom 
Number Generators for Cryptographic Applica�on” on the address: 

 In the  sec�on, you can set the length of the bit sequence, in bits, the number of all Parameters
sequences used in the test procedure and the level of significance (alpha).

 NOTE: If the sequence length and the number of sequences are in the upper limit, the test �me 
may exceed tens of hours. 
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 3.5.10 Calibra�on
 
 , . This instrument To ac�vate this mode from the Main menu click Tools → Calibra�on
calibrates GTR-01 in manual or automa�c mode.

StudioGTR Calibra�on.

 The instrument is ac�ve in  mode only.NOTE True: 

 In the  sec�on, you can read the current values of calibra�on coefficients for the Coefficients
two generator hardware channels. You can set the new values manually and write them to the device. 
When the Write to EEPROM is set, the values will be saved to the device EEPROM. 

 In the  sec�on, you can start an automa�c calibra�on procedure and then, if you wish, Control
write the calculated coefficient values to the GTR-01 memory.

 :NOTE  GTR-01 does not implement a Factory Reset func�on.
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 3.6 Se�ngs

 3.6.1 Channel
 
 , To set the ac�ve hardware channel of the GTR-01 from the Main menu click Se�ngs → 
Channel. :The program allows the following op�ons
 Channel A. Data are generated only by channel A. 
 Channel B. Data are generated only by channel B.
 XOR (Channel A XOR Channel B). Logical bitwise XOR between two channels (default mode).
 XOR plus. Same as in the previous mode but with some addi�onal improvements. The 
genera�on speed is slightly decreased.
 XOR DeBias. Same as in the default mode but with the addi�on of John von Neumann’s 
debiasing procedure. The genera�on speed is decreased.

 3.6.2 Transfer
 
  , . To set the transfer mode of the GTR-01 from the Main menu click The Se�ngs → Transfer
program allows the following op�ons:
 Synchronous (default). 
 Asynchronous.

  Internally, GTR-01 implements two basic modes of data acquisi�on.NOTE:

 In the so-called Synchronous mode, data are collected in a single buffer whenever a data 
request from the host (PC) has been made. In such a way, the device (GTR-01) is idling un�l a new 
request is received and data packets are synchronized with the host opera�on, providing good 
predictability and �me precision. This mode is suitable in situa�ons where the exact moments of data 
acquisi�on should be controlled by the host.

Synchronous mode of opera�on.
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 LCG (Linear congruen�al generator).

 3.6.3 Pseudorandom Generator
 
  , To set the type of the pseudorandom generator used in StudioGTR from the Main menu click 
Se�ngs → Pseudorandom Generator. :The program allows the following op�ons
 .NET (default). .NET pseudorandom number generator.
 .NET Crypto. .NET cryptographicaly secure pseudorandom number generator.

 MWC (Mul�ply-with-carry). The generator is invented by George Marsaglia.

 Combo (LCG+MWC+Xorshi�).
 Xorshi�. The generator is invented by George Marsaglia.

Asynchronous mode of opera�on.

 On the other side, the so-called Asynchronous mode implements internally the Ping-pong 
scheme where data are con�nuously collected in the two separate data buffers and independently 
from the host requests. A�er one buffer has been filled with data, acquisi�on con�nues in the other 
one without any interrup�on and so on. The two buffers are constantly swapping one a�er another, 
hence the name ping-pong. When the host request arrives, the transfer of the last ready buffer filled 
with fresh data can start immediately, and in such a way, no �me is lost in wai�ng for the buffer to be 
filled. This mode is suitable when the main goal is a maximum speed of opera�on with the highest 
possible transfer rate.
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 3.7 Mul�lingual support

 To change the current applica�on language:
 From the Main menu click on  to select the language you prefer.Se�ngs → Language
 In the popup dialog box, confirm your selec�on and StudioGTR will automa�cally close and 
restart with the new language se�ngs.

 StudioGTR is an applica�on designed with built-in mul�lingual support .

  When the applica�on is star�ng for the first �me on your computer, the default language NOTE:
is English. 

 NOTE: The applica�on help file launches in the language version corresponding to the current 
applica�on language.
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 When you are ready click OK bu�on. The preferences will take place immediately. On the next 
launch StudioGTR will start with the new se�ngs.

 To launch the Preferences box, from the Main menu click on Se�ngs → Preferences...

 StudioGTR allows for customiza�on through se�ng user’s preferences . 

 In the Event Logger page you can choose the directory path for automa�c data recording. 

 In the Graphics page you can choose the point and progress bar colors and set the point size. 
Click on the Reset bu�on if you want to set back colors to their default values.

 3.8 Applica�on preferences

Preferences dialog box.
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 GTR-01 is specially designed as a high-quality, high-speed source of true random numbers. It 
can be used in areas requiring a high degree of randomness and unpredictability. And if the StudioGTR 
applica�on allows for some basic observa�ons and calibra�on procedures to be performed, the 
complete set of all capabili�es, embedded in the GTR-01, can be achieved only through the power of 
the low-level device communica�on. This approach requires some basic programming skills. See 
Appendix A and Appendix B of this guide for more examples, using Microso� C# programming 
language. 
 GTR-01 u�lizes an FTDI USB interface chip and needs an FTDI driver pack to be installed on the 
PC. Please read the driver documenta�on and applica�on notes on the driver vendor’s site.

  4. Low level API

 
  Communica�ng with the GTR-01 requires USB drivers to be installed first. Fore more NOTE:
informa�on on how to install the driver pack, please see sec�on 3.5. 

 4.1 GTR-01 IO commands

  You must always write 64 bytes to the GTR-01 and read back 4096 bytes!IMPORTANT:

 Descrip�on of the low level GTR-01 IO commands  is given below.

 NOTE: For maximum transfer speed, use asynchronous IO commands. Otherwise, use 
synchronous ones.

www.benev.bizGTR-01

GTR-01 User Manual Rev. 2.3 – 17 Apr 2024

https://benev.biz
https://benev.biz


27

GET_RND_CHANNEL_A

GET_RND_NORMAL_DEBIAS

 0x01

 0x02 

0x11

0x23

0x31

IO Command

0x32

Value

GET_RND_NORMAL

GET_RND_NORMAL_PLUS

 0x12

 0x21 

0x22

SET_CALIBRATION

GET_CALIBRATION

 0x41

 0x42 

0x51

0x81

0x82GET_DEVICE_ID 

 0x52

 0x53 

0x80

GET_RND_CHANNEL_A_CALIBRATION

GET_RND_CHANNEL_B

GET_RND_CHANNEL_B_CALIBRATION

GET_RND_CHANNEL_A_ASYNC

GET_RND_NORMAL_DEBIAS_ASYNC

GET_RND_NORMAL_ASYNC

GET_RND_NORMAL_PLUS_ASYNC

GET_RND_CHANNEL_A_CALIBRATION_ASYNC

GET_RND_CHANNEL_B_ASYNC

GET_RND_CHANNEL_B_CALIBRATION_ASYNC

0x55EEPROM_WRITE* 

 * The command should be wri�en to the second byte. See the explana�on below.

 4.1.1  GET_RND_CHANNEL_A

 Write: 
  Byte0    0x01
  Byte1 to Byte63  No ma�er

 Read:
  Byte0 to Byte4095  Random bytes from channel A, synchronous transfer
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 Read:

  Byte0 to Byte4095  Random bytes from channel A, synchronous transfer. 
The bytes returned are “as is” without any so�ware 
improvements. Use this command when calibra�ng 
channel A.

 4.1.3  GET_RND_CHANNEL_B

 Write: 
  Byte0    0x11

  Byte0    0x02

  Byte1 to Byte63  No ma�er

  Byte1 to Byte63  No ma�er

  Byte0    0x12

 Write: 

  Byte0 to Byte4095  Random bytes from channel B, synchronous transfer. 
The bytes returned are “as is” without any so�ware 
improvements. Use this command when calibra�ng 
channel B.

  Byte0 to Byte4095  Random bytes from channel B, synchronous transfer

 Write: 

  Byte0 to Byte4095  Random bytes from channel A XOR channel B,      

 Write: 

 4.1.4  GET_RND_CHANNEL_B_CALIBRATION

 4.1.2  GET_RND_CHANNEL_A_CALIBRATION

 Read:

 Read:

  Byte1 to Byte63  No ma�er

 4.1.5  GET_RND_NORMAL

      synchronous transfer

 Read:

  Byte0    0x21
  Byte1 to Byte63  No ma�er
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 Read:

  Byte0    0x22

  Byte0 to Byte4095  Random bytes from channel A XOR channel B,           
synchronous transfer. Implements John von 
Neumann’s debiasing algorithm.

  Byte0    0x31

 4.1.6  GET_RND_NORMAL_PLUS

  Byte0 to Byte4095  Random bytes from channel A XOR channel B,           
synchronous transfer. Iden�cal to GET_RND_NORMAL 
with some so�ware improvements of the output data 
quality.

 Write: 

  Byte1 to Byte63  No ma�er

 4.1.7  GET_RND_NORMAL_DEBIAS

 Write: 

  Byte1 to Byte63  No ma�er
  Byte0    0x23

 Read:

 4.1.8  GET_RND_CHANNEL_A_ASYNC

 Write: 

  Byte1 to Byte63  No ma�er

  Byte0 to Byte4095  Random bytes from channel A, asynchronous transfer

 4.1.9  GET_RND_CHANNEL_A_CALIBRATION_ASYNC

 Write: 

  Byte1 to Byte63  No ma�er

 Read:

  Byte0    0x32

 Read:
  Byte0 to Byte4095  Random bytes from channel A, asynchronous transfer. 

The bytes returned are “as is” without any so�ware 
improvements. Use this command when calibra�ng 
channel A.
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  Byte0 to Byte4095  Random bytes from channel A XOR channel B,           
asynchronous transfer. Iden�cal to 
GET_RND_NORMAL_ASYNC with some so�ware 
improvements of the output data quality.

  Byte0    0x52
  Byte1 to Byte63  No ma�er

 Read:

  Byte0 to Byte4095  Random bytes from channel B, asynchronous transfer. 
The bytes returned are “as is” without any so�ware 
improvements. Use this command when calibra�ng 
channel B.

  Byte1 to Byte63  No ma�er

 Write: 

 Read:

 4.1.13  GET_RND_NORMAL_PLUS_ASYNC

 Write: 
  Byte0    0x51

  Byte0 to Byte4095  Random bytes from channel A XOR channel B,      
      asynchronous transfer

 4.1.12  GET_RND_NORMAL_ASYNC

 Read:

 Read:

 4.1.10  GET_RND_CHANNEL_B_ASYNC

 Write: 

 Write: 

  Byte0    0x42

  Byte0 to Byte4095  Random bytes from channel B, asynchronous transfer

 4.1.11  GET_RND_CHANNEL_B_CALIBRATION_ASYNC

  Byte1 to Byte63  No ma�er

  Byte1 to Byte63  No ma�er
  Byte0    0x41
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  Byte2    Channel B calibra�on value, 12-bit unsigned, byte0 
  Byte3    Channel B calibra�on value, 12-bit unsigned, byte1
  Byte4 to Byte4095  No meaning

 4.1.14  GET_RND_NORMAL_DEBIAS_ASYNC

 Write: 
  Byte0    0x53

 Read:
  Byte0 to Byte4095  Random bytes from channel A XOR channel B,           

asynchronous transfer. Implements John von 
Neumann’s debiasing algorithm.

 4.1.15  SET_CALIBRATION

  Byte1 to Byte63  No ma�er

 Write:
  Byte0    0x80

                  Don’t write to EEPROM
  Byte2    Reserved
  Byte3    Reserved
  Byte4    Channel A calibra�on value, 12-bit unsigned, byte0 
  Byte5    Channel A calibra�on value, 12-bit unsigned, byte1 

  Byte1    0x55 - Write to EEPROM; Otherwise - 

  Byte1    Channel A calibra�on value, 12-bit unsigned, byte1 

  Byte7    Channel B calibra�on value, 12-bit unsigned, byte1
  Byte8 to Byte63  No ma�er

  Byte0    0x81

  Byte6    Channel B calibra�on value, 12-bit unsigned, byte0 

 Read:

 Write: 

  Byte1 to Byte63  No ma�er

  Byte1 to Byte4095  No meaning
  Byte0    EEPROM write status, 0 means OK

 4.1.16  GET_CALIBRATION

 Read:
  Byte0    Channel A calibra�on value, 12-bit unsigned, byte0 
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  Byte6    Device ID, -bit unsigned integer, byte664
  Byte5    Device ID, -bit unsigned integer, byte564

 4.1.17  GET_DEVICE_ID

 Write:

  Byte0    Device ID, 64-bit unsigned integer, byte0 

  Byte3    Device ID, -bit unsigned integer, byte3 64
  Byte4    Device ID, -bit unsigned integer, byte4 64

  Byte1    Device ID, -bit unsigned integer, byte1 64
  Byte2    Device ID, -bit unsigned integer, byte2 64

  Byte7    Device ID, -bit unsigned integer, byte7  64

  Byte0    0x82
  Byte1 to Byte63  No ma�er

 Read:

  Byte8 to Byte4095  No meaning
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 The randomness and unpredictability of the generated output data stream numbers have been 
validated using the following sta�s�cal test ba�eries:

  Appendix A: Sta�s�cal tests

NIST STS  h�ps://csrc.nist.gov/projects/random-bit-genera�on

Test Website

TestU01

Diehard

 h�p://simul.iro.umontreal.ca/testu01/tu01.html

 h�ps://web.archive.org/web/20160125103112/h�p://stat.fsu.edu/pub/diehard/

  More informa�on about the test procedure you can find here:NOTE:
h�ps://benev.biz/en/sta�s�cal-tes�ng-random-generators.html
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  Appendix B: FTDI IO methods wrapper in C# 

 This is an example of using C# programming language and P/Invoke technology to wrap some 
basic IO methods, originally wri�en in C and described in the D2XX Programmer's Guide at 
h�ps://�dichip.com The code shown below is located in the GTR_IO_wrap.cs file found in the 
StudioGTR.zip archive.

using System;

namespace GTR
{
 // FT_STATUS enumeration.

 {
  FT_OK = 0,
  FT_INVALID_HANDLE,
  FT_DEVICE_NOT_FOUND,

  FT_IO_ERROR,

 public enum uint   : FT_STATUS

  FT_INSUFFICIENT_RESOURCES,

  FT_DEVICE_NOT_OPENED,

using System.Runtime.InteropServices;

  FT_INVALID_PARAMETER,
  FT_INVALID_BAUD_RATE,

using System.Text;

  FT_EEPROM_NOT_PRESENT,

  [ ( .ByValTStr, SizeConst = 16)]MarshalAs UnmanagedType

  public uint  Flags;

  FT_EEPROM_READ_FAILED,

 }

  public string  Description;

  FT_INVALID_ARGS,

  public string  SerialNumber;

  FT_NOT_SUPPORTED,

 public struct  FT_DEVICE_LIST_INFO_NODE

  public uint  ID;

  [ ( .ByValTStr, SizeConst = 64)]MarshalAs UnmanagedType

  FT_FAILED_TO_WRITE_DEVICE,

 }

  FT_DEVICE_NOT_OPENED_FOR_ERASE,

 // FT_DEVICE_LIST_INFO_NODE struct.

  FT_EEPROM_NOT_PROGRAMMED,

  public uint  Type;

  FT_DEVICE_NOT_OPENED_FOR_WRITE,

  FT_EEPROM_ERASE_FAILED,

 [ ( .Sequential)]StructLayout LayoutKind

 {

  public uint  LocId;

  FT_EEPROM_WRITE_FAILED,

  public  ftHandle;IntPtr

  FT_OTHER_ERROR
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        ref uint  lpdwBytesReturned);

  public static extern    FT_SetBaudRate(  ftHandle, FT_STATUS IntPtr

  public static extern ref uint    FT_ListDevices(   pvArg1,FT_STATUS

         uint dwFlags);
         uint pvArg2,

  public const uint   FT_PURGE_TX = 2;

  [ ( )]DllImport "FTD2XX.dll"

       ref uint  lpdwNumDevs);
       [ , ] [] pDest,In Out FT_DEVICE_LIST_INFO_NODE

  [ ( )]DllImport "FTD2XX.dll"

  [ ( )]DllImport "FTD2XX.dll"

        uint dwBytesToRead, 

  // Classic Interface Methods.
  [ ( )]DllImport "FTD2XX.dll"

  public static extern    FT_GetDeviceInfoList(FT_STATUS

  [ ( )]DllImport "FTD2XX.dll"

         ref  ftHandle);IntPtr

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_Read(  ftHandle, FT_STATUS IntPtr
        [ , ] [] lpBuffer, In Out byte

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_Write(  ftHandle, FT_STATUS IntPtr
         [ , ] [] lpBuffer, In Out byte

  public static extern ref uint    FT_CreateDeviceInfoList(   lpdwNumDevs);FT_STATUS

  public static extern int    FT_Open(  iDevice, FT_STATUS

  [ ( )]DllImport "FTD2XX.dll"

  public static extern    FT_Close(  ftHandle);FT_STATUS IntPtr

         uint dwBytesToWrite,
         ref uint  lpdwBytesWritten);

  [ ( )]DllImport "FTD2XX.dll"

         uint dwBaudRate);

  public static extern    FT_SetDivisor(  ftHandle, FT_STATUS IntPtr
        ushort usDivisor);

 public class  FTDI

  // Flags.

 // FTDI class.

 {        

  public const uint   FT_LIST_NUMBER_ONLY   = 0x80000000u; 
  public const uint   FT_LIST_BY_INDEX      = 0x40000000u;
  public const uint   FT_LIST_ALL           = 0x20000000u;

  public const uint   FT_OPEN_BY_SERIAL_NUMBER  = 1u;

  // Word Lengths.

  public const ushort ushort   FT_FLOW_NONE     = ( )0x0000;

  public const byte byte   FT_PARITY_ODD   = ( )1;

  public const byte byte   FT_PARITY_SPACE = ( )4;

  // Stop Bits.

  public const ushort ushort   FT_FLOW_RTS_CTS  = ( )0x0100;

  // Flow Control.

  public const ushort ushort   FT_FLOW_DTR_DSR  = ( )0x0200;
  public const ushort ushort   FT_FLOW_XON_XOFF = ( )0x0400;

  public const byte byte   FT_PARITY_NONE  = ( )0;

  // Purge rx and tx buffers.
  public const uint   FT_PURGE_RX = 1;

  public const byte byte   FT_STOP_BITS_1  = ( )0;

  public const uint   FT_OPEN_BY_LOCATION       = 4u;
  public const uint   FT_OPEN_BY_DESCRIPTION    = 2u;

  public const byte byte   FT_BITS_8 = ( )8;
  public const byte byte   FT_BITS_7 = ( )7;

  // Parity.

  public const byte byte   FT_PARITY_EVEN  = ( )2;

  public const byte byte   FT_STOP_BITS_2  = ( )2;

  public const byte byte   FT_PARITY_MARK  = ( )3;
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             byte uStopBits,

            ushort usFlowControl, 
  public static extern    FT_SetFlowControl(  ftHandle, FT_STATUS IntPtr

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_SetDataCharacteristics(  ftHandle, FT_STATUS IntPtr
             byte uWordLength,

             byte uParity);

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_SetTimeouts(  ftHandle, FT_STATUS IntPtr
         uint dwReadTimeout, 
         uint dwWriteTimeout);

  [ ( )]DllImport "FTD2XX.dll"

            byte uXon,
            byte uXoff);

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_GetDeviceInfo(  ftHandle,FT_STATUS IntPtr
           ref uint  pftType,

           StringBuilder pcSerialNumber,

           int pvDummy);

  [ ( )]DllImport "FTD2XX.dll"

           ref uint  lpdwID,

           StringBuilder pcDescription,

  public static extern    FT_GetDriverVersion(  ftHandle, FT_STATUS IntPtr
              ref uint  lpdwDriverVersion);

             ref byte  pucTimer);

  [ ( )]DllImport "FTD2XX.dll"

        byte ucMode);

  [ ( )]DllImport "FTD2XX.dll"

  [ ( )]DllImport "FTD2XX.dll"

              uint dwInTransferSize, 

  public static extern    FT_SetBitMode(  ftHandle,FT_STATUS IntPtr

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_ResetPort(  ftHandle);FT_STATUS IntPtr

  public static extern    FT_GetBitMode(  ftHandle,FT_STATUS IntPtr

  // Extended API Functions.

  [ ( )]DllImport "FTD2XX.dll"

  [ ( )]DllImport "FTD2XX.dll"

  [ ( )]DllImport "FTD2XX.dll"

           ushort wPID);

  [ ( )]DllImport "FTD2XX.dll"

  public static extern    FT_CyclePort(  ftHandle);FT_STATUS IntPtr

          uint dwMask);

  public static extern    FT_GetLatencyTimer(  ftHandle,FT_STATUS IntPtr

  [ ( )]DllImport "FTD2XX.dll"

  [ ( )]DllImport "FTD2XX.dll"
  public static extern    FT_Purge(  ftHandle, FT_STATUS IntPtr

  public static extern    FT_ResetDevice(  ftHandle);FT_STATUS IntPtr

  [ ( )]DllImport "FTD2XX.dll"

  public static extern    FT_Rescan();FT_STATUS

  public static extern ref uint    FT_GetLibraryVersion(   lpdwDLLVersion);FT_STATUS

  public static extern    FT_SetLatencyTimer(  ftHandle,FT_STATUS IntPtr
             byte ucTimer);

  public static extern ushort    FT_Reload(  wVID, FT_STATUS

  [ ( )]DllImport "FTD2XX.dll"

 

        byte ucMask,

        ref byte  pucMode);

  public static extern    FT_SetUSBParameters(  ftHandle,FT_STATUS IntPtr

              uint dwOutTransferSize);
 }
}
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  Appendix C: GTR-01 IO example 

 This is an example describing GTR-01 basic IO communica�on. The code is wri�en in C# and is 
located in the class GTR_IO in GTR_IO_ex.cs file. The example uses an interface wrapper in the 
GTR_IO_wrap.cs file. Both source files are located in the StudioGTR.zip archive.

 // GTR_IO class.

 {
  // Constants.
  private const ushort   VID = 0x0403;
  private const ushort   PID = 0x6015;      // FTDI's original PID and VID.

using System;

namespace GTR

 public class  GTR_IO

  private const uint   BYTES_TO_WRITE   = 64u;
  private const uint   BYTES_TO_READ   = 4096u;

{

  private const byte byte      EEPROM_WRITE_CONST  = ( )0x55;

           GET_CALIBRATION_REQUEST     = ( )0x81; private const byte byte
           GET_DEVICE_ID_REQUEST     = ( )0x82; private const byte byte

  // Constructor.

  }
    

           GET_RND_CHANNEL_A_CALIBRATION_REQUEST   = ( )0x02; public const byte byte

  { 

           GET_RND_NORMAL_PLUS_REQUEST    = ( )0x22; public const byte byte

  public GTR_IO() 

           GET_RND_CHANNEL_B_ASYNC_REQUEST    = ( )0x41; public const byte byte

           GET_RND_NORMAL_ASYNC_REQUEST    = ( )0x51; public const byte byte

           GET_RND_CHANNEL_A_ASYNC_REQUEST    = ( )0x31; public const byte byte

           GET_RND_CHANNEL_A_REQUEST     = ( )0x01; public const byte byte

           SET_CALIBRATION_REQUEST     = ( )0x80; private const byte byte

           GET_RND_CHANNEL_B_CALIBRATION_ASYNC_REQUEST  = ( )0x42; public const byte byte

           GET_RND_NORMAL_DEBIAS_ASYNC_REQUEST   = ( )0x53; public const byte byte

           GET_RND_NORMAL_REQUEST     = ( )0x21; public const byte byte

           GET_RND_NORMAL_DEBIAS_REQUEST    = ( )0x23; public const byte byte

           GET_RND_CHANNEL_A_CALIBRATION_ASYNC_REQUEST  = ( )0x32; public const byte byte

           GET_RND_CHANNEL_B_CALIBRATION_REQUEST   = ( )0x12; public const byte byte

           GET_RND_NORMAL_PLUS_ASYNC_REQUEST    = ( )0x52; public const byte byte

           GET_RND_CHANNEL_B_REQUEST     = ( )0x11; public const byte byte
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                  {

    FTDI.FT_SetBaudRate(handle, 3000000u);

   try

  

    status = .FT_GetDeviceInfoList(vDevInfo,  numDevs);FTDI ref

    if ref ( .FT_Open(0,  handle) != .FT_OK)FTDI FT_STATUS

   IntPtr IntPtr handle = .Zero;

    // Open GTR device.

    }

  {

    string vidpid = .Format( , GTR_IO.VID, GTR_IO.PID);String "{0:X4}{1:X4}"

  

                       // There is something wrong or device is not connected.

                 (status == FT_STATUS.FT_OK &&   if

                       // GTR is connected.

             String.Format( , vDevInfo[0].ID) == vidpid)"{0:X8}"

                  }

                  {

    status = .FT_CreateDeviceInfoList(  numDevs);FTDI ref

    FT_DEVICE_LIST_INFO_NODE[] vDevInfo = 

   {

    {
     throw new  ( );Exception "Device not found!"

    // Check for GTR device.

  // Public methods.

    FT_STATUS FT_STATUS status = .FT_OK;

  public void  GTR_Basic_IO()

    uint numDevs = 0u;

      new [numDevs];FT_DEVICE_LIST_INFO_NODE

                  else

                  }

    // Initialize GTR device.

    FTDI.FT_SetDataCharacteristics( handle,
          FTDI.FT_BITS_8,
          FTDI.FT_STOP_BITS_1, 
          FTDI.FT_PARITY_NONE);

    FTDI.FT_SetTimeouts(handle, 3000u, 1000u);
    FTDI FTDI FTDI.FT_Purge(handle, .FT_PURGE_RX | .FT_PURGE_TX);

    uint bytesToRead = .BYTES_TO_READ;GTR_IO
    uint bytesWritten = 0u;

    // IO communication.

    uint bytesReturned = 0u;
    byte new byte[] bufferWrite =  [bytesToWrite];
    byte new byte[] bufferRead =  [bytesToRead];

    status = .FT_Write(handle,FTDI
       bufferWrite,

       ref bytesWritten);

    FTDI FTDI.FT_SetFlowControl(handle, .FT_FLOW_RTS_CTS, 0, 0);

    uint bytesToWrite = .BYTES_TO_WRITE;GTR_IO

    bufferWrite[0] = .GET_RND_NORMAL_REQUEST;GTR_IO

       bytesToWrite,

    status = .FT_Read(handle,FTDI

       bytesToRead,
       ref bytesReturned);

       bufferRead,

    if (status != .FT_OK)FT_STATUS

    }
     throw new  ( );Exception "USB communication problem!"
    {
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    // Displaying the result.
    for int (  i = 0; i < bufferRead.Length; i++)
    {

   }
   catch (  exc)Exception

     Console.Write( , bufferRead[i]);"{0:x2}"
    }
    Console.WriteLine();

   {
    // If something goes wrong, show the explanation here.

    // When the IO is completed, close GTR device.
    FTDI.FT_Close(handle);

    Console.WriteLine(exc.Message);

   finally

  }
 }

   }

}

   {

   }
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Comparator
Cryptography

Brown noise

Avalanche noise
Asynchronous mode

Box-Muller transform
Breakdown voltage

Calibra�on values

Debiasing

EEPROM

Flicker noise

Deple�on region
Digital-to-analog converter (DAC)

George Marsaglia

Linear congruen�al generator

Drivers

John von Neumann

  Index

Synchronous mode

NIST

P-n junc�on

Red noise

Shot noise

Random walk

Reverse biased voltage

Mul�ply-with-carry

N-region

Quantum noise

RGB

Ping-pong

White noise

P-region

Xorshi�
22, 29, 31

23

1, 21

1, 3

3

16

23

21

5, 6, 7

 23

3
16

4

16

4

1, 23

22, 29, 31

23

3

20

16

23

16

3

23

22

15

16

3

3

3

3
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